前端学堂(好切网)-Web前端开发,网页切图教程分享平台
前端学堂(好切网),PS网页切图,专业WEB前端外包网站
您的位置:首页 > 前端学堂 > JavaScript

jquery两个不同版本冲突如何解决?

2017-04-06 08:51:14分类:JavaScript阅读(294)

jQuery不同版本会引发冲突,引起冲突的原因主要是常用的$符号的问题,这个问题还是比较容易解决的, jquery早早就有给我们预留处理方法了,下面一起来看看解决办法

jquery不同版本冲突的解决办法:

<script src="js/jquery1.4.2.js"></script>
<script type="text/javascript">
    var jq142 = jQuery.noConflict(true);
</script>

<script src="js/jquery1.10.2.js"></script>
<script type="text/javascript">
    var jq1102 = jQuery.noConflict(true);
</script>

给他们一个新的命名,你使用不同的库时,你可以选择用哪个库的函数,这样避免了他们之间的冲突。

下面是用的第一个jQuery(jquery1.4.2.js)中的函数:

<script type="text/javascript">
    jq142(function($){
        $('#header');
        //此时的$是jquery1.4.2.js
    });
</script>

下面是用的第二个jQuery的函数:

<script type="text/javascript">
    jq1102(function($){
        $('#header');
        //此时的$是jquery1.10.2.js
    });
</script>

这样让他们能唯一对应自己库里边的函数,从而避免冲突。

 

原文链接:http://www.hqhtml.com/javascript/33.html,出自好切网(前端学堂),转载请注明出处。
相关阅读 ~
推荐文章

© 2016 好切网(hqhtml.com) 长春诺阳科技有限公司(网页前端切图) 版权所有 吉ICP备15007500号